Перейти к содержанию
Форум русской поддержки продукции Synology

DS Cam и порт 5000


Рекомендованные сообщения

В общем вопрос в следующем.

Хочу пробросить порт 5000 для того что-б DS Cam ходил на сервер напрямую по айпишнику (а не через задницу в виде quickconnect).

Но проблема в том что порт 5000 - это собственно вебморда Synology. Т.е. если я проброшу порт 5000 - страница входа на мою Synology будет светить на весь интернет)

Возможно-ли сделать так что-б DS Cam таки заходил через порт 5000, но заглавная страница не светилась?

Какие есть мысли по этому поводу?

Ссылка на сообщение
Поделиться на другие сайты
  • Ответов 64
  • Создано
  • Последний ответ

Лучшие авторы в этой теме

Лучшие авторы в этой теме

Возможно-ли сделать так что-б DS Cam таки заходил через порт 5000, но заглавная страница не светилась?

Какие есть мысли по этому поводу?

Изменить порт вебморды.

 

Ссылка на сообщение
Поделиться на другие сайты
В общем вопрос в следующем.

Хочу пробросить порт 5000 для того что-б DS Cam ходил на сервер напрямую по айпишнику (а не через задницу в виде quickconnect).

Но проблема в том что порт 5000 - это собственно вебморда Synology. Т.е. если я проброшу порт 5000 - страница входа на мою Synology будет светить на весь интернет)

Возможно-ли сделать так что-б DS Cam таки заходил через порт 5000, но заглавная страница не светилась?

Какие есть мысли по этому поводу?

 

странно , у меня ходит напрямую по ddns без QC внешний порт 5000 отсутствует...

Ссылка на сообщение
Поделиться на другие сайты
странно , у меня ходит напрямую по ddns без QC внешний порт 5000 отсутствует...

Это как?

Чудес не бывает)

Какой-то порт все равно должен быть проброшен. Может у вас 5001 проброшен?

Посмотрите на роутере.

Может у вас вообще фаер вырублен?

Ссылка на сообщение
Поделиться на другие сайты
Изменить порт вебморды.

В таком случае вебморда все равно будет светить в интернет. Просто вместо порта 5000 или 5001 будет 28506 например...

Ссылка на сообщение
Поделиться на другие сайты
Это как?

Чудес не бывает)

Какой-то порт все равно должен быть проброшен. Может у вас 5001 проброшен?

Посмотрите на роутере.

Может у вас вообще фаер вырублен?

1. у меня натирование, так что проброс портов возможен только ручками или через upnp (который выключен)

2. никаких стандартных портов наружу нет вообще, включая портов управления. Открываю только по необходимости.

3. DS CAM отлично работает.

Под web SS сделано в штатном механизме отдельное имя.

Ссылка на сообщение
Поделиться на другие сайты
1. у меня натирование, так что проброс портов возможен только ручками или через upnp (который выключен)

2. никаких стандартных портов наружу нет вообще, включая портов управления. Открываю только по необходимости.

3. DS CAM отлично работает.

Под web SS сделано в штатном механизме отдельное имя.

А вы проверьте например вот этим - http://www.wservice.info/?checkport

DS Cam не будет работать без открытых 5000 или 5001 портов. Ну или будет но только через квикконнект.

На всякий случай еще 9900 и 9901 посмотрите...

Ссылка на сообщение
Поделиться на другие сайты
В таком случае вебморда все равно будет светить в интернет. Просто вместо порта 5000 или 5001 будет 28506 например...

А сейчас почему не светит?

Вебморда не будет работать без открытого порта 28506. А DS Cam будет работать при открытом порте 5000

Ссылка на сообщение
Поделиться на другие сайты
А вы проверьте например вот этим - http://www.wservice.info/?checkport

DS Cam не будет работать без открытых 5000 или 5001 портов. Ну или будет но только через квикконнект.

На всякий случай еще 9900 и 9901 посмотрите...

Все перечисленное - закрыто. Замечу что 9900 и 9901 это вообще необязательные порты. И прямой доступ к веб ss можно сделать без них , через отдельное имя.

80 порт тоже закрыт.

Хожу не через qc. Там видео в реальном времени не пролезает...

Ссылка на сообщение
Поделиться на другие сайты
Все перечисленное - закрыто. Замечу что 9900 и 9901 это вообще необязательные порты. И прямой доступ к веб ss можно сделать без них , через отдельное имя.

80 порт тоже закрыт.

Хожу не через qc. Там видео в реальном времени не пролезает...

Очень интересно.

Либо вы нашли как побороть эту проблему, либо что-то не так)

В документации прямо написано что DS Cam работает через порты 5000 или 5001

Если они закрыты - то как оно может работать?

Ссылка на сообщение
Поделиться на другие сайты
А сейчас почему не светит?

Вебморда не будет работать без открытого порта 28506. А DS Cam будет работать при открытом порте 5000

На всякий случай попробовал.

И естественно это НЕ работает.

Когда я меняю порт вебморды с 5000 на 28506, сканер показывает что порт 5000 закрыт) Что в общем и понятно.

DS Cam естественно тоже НЕ работает так как стучится на порт 5000 которого теперь нет.

Если вместо порта 5000 я пробрасываю на роутере новый порт 28506 и в DS Cam в адресе указываю айпишник и порт 28506 - то естественно все работает. Как и вебморда на порту 28506

Короче шило на мыло.

Ссылка на сообщение
Поделиться на другие сайты

Так.

Путем некоторых экспериментов, всплыли интересные детали)

 

Оказывается мобильное приложение DS Cam умеет работать не только со стандартными портами вебморды DSM (5000 и 5001) но и с портами Surveillance Station! Те которые 9900 и 9901

В Портале приложений в Панели управления нужно включить пользовательский порт 9900 или 9901 для SS.

Дале на маршрутизаторе пробрасываем эти порты (или один из них).

Далее запускаем DS Cam и в адресной строке вбиваем айпиадрес:9900 или айпиадрес:9901 и оно РАБОТАЕТ! Даже без проброса портов 5000 или 5001.

 

Естественно в интернет теперь будет светить вебморда Surveillance Station которая висит на портах 9900 и 9901

Но это лучше чем светить в интернет вcю DSM через порты 5000 и 5001.

 

Короче половина дела сделана)

 

Если-б можно было как-то заглушить вебморду Surveillance Station (она мне и не нужна через веб), то проблема собственно решена. В интернет светят порты 9901 и 9900 к которым подключается DS Cam и при этом на этих портах не висят никакие вебинтерфейсы.

 

ЗЫ

В настройках портала приложений есть пункт "Скрыть баннер". Это что вообще?

Ссылка на сообщение
Поделиться на другие сайты
1. у меня натирование, так что проброс портов возможен только ручками или через upnp (который выключен)

2. никаких стандартных портов наружу нет вообще, включая портов управления. Открываю только по необходимости.

3. DS CAM отлично работает.

Под web SS сделано в штатном механизме отдельное имя.

Никак не могу понять как вы это сделали...

 

Что вы прописываете в адресной строке DS Cam?

Что у вас прописано в Портале приложений относительно SS?

Ссылка на сообщение
Поделиться на другие сайты
Никак не могу понять как вы это сделали...

 

Что вы прописываете в адресной строке DS Cam?

Что у вас прописано в Портале приложений относительно SS?

В строке я пишу имя qc

В портале приложений указано имя для ss. Порты не указаны.

Ссылка на сообщение
Поделиться на другие сайты
В строке я пишу имя qc

Если вы пишете адрес QC - видео с вашего NAS идет к вам через Тайвань по ВПН который ваш NAS автоматически поднимает к облаку Synology. В таком случае естественно никакие порты открывать не надо... но все тормозит.

Правда если вы внутри сети в которой стоит NAS, QC может редиректнуть вас напрямую на NAS.

Ссылка на сообщение
Поделиться на другие сайты
В портале приложений указано имя для ss. Порты не указаны.

Типа cam.example.com?

Или example.com/cam?

Ссылка на сообщение
Поделиться на другие сайты
На всякий случай попробовал.

И естественно это НЕ работает.

Когда я меняю порт вебморды с 5000 на 28506, сканер показывает что порт 5000 закрыт) Что в общем и понятно.

DS Cam естественно тоже НЕ работает так как стучится на порт 5000 которого теперь нет.

Если вместо порта 5000 я пробрасываю на роутере новый порт 28506 и в DS Cam в адресе указываю айпишник и порт 28506 - то естественно все работает. Как и вебморда на порту 28506

Короче шило на мыло.

Менять то нужно в самом NAS.

08a96aad8a7eb53320c9d77776a91bf3.jpeg

Ссылка на сообщение
Поделиться на другие сайты
Если вы пишете адрес QC - видео с вашего NAS идет к вам через Тайвань по ВПН который ваш NAS автоматически поднимает к облаку Synology. В таком случае естественно никакие порты открывать не надо... но все тормозит.

Правда если вы внутри сети в которой стоит NAS, QC может редиректнуть вас напрямую на NAS.

1. Qc всегда вначале осуществляет редирект на nas по ip. И без разницы внутри сети или вне. Внутри сети пойдет loopback... Но только после запроса через вне, с получением ip. Если бы было как думаете вы, то роутер не смог бы сделать loopback, без ip это невозможно...

Никакого трафика при этом через сервера syno не идёт. Только запрос актуального адреса для нужной службы.

Я через videostation так смотрю потоковое видео fhd и 4k. Сомнительно что qc , который интерфейс со скрежетом открывает, даст тянуть такой поток.

2. Причем тут Тайвань? Все редиректы идут через сервера Чехии или Германии. У меня на работе закрыты порты отличные от 80, 8080, 443. По мнению qc доступ к нему есть и меня все время пытается редиректить на мой актуальный белый динамический ip. При 3-4 попытках удается заставить идти через оптимальный ресурс это обычно Чехия или Германия. 1 раз были штаты...

Ссылка на сообщение
Поделиться на другие сайты
Типа cam.example.com?

Или example.com/cam?

Конечно второе. Доменное имя низлежащего уровня не формируется.

Ссылка на сообщение
Поделиться на другие сайты
Естественно на NASе и меняю.

Не работает.

В NAS меняете порт 5000 на любой другой. В модеме открываете порт 5000.

Только что на своём NAS проверил. Работает.

Вебморда не доступна, а DS cam работает.

В DS cam ввёл имя.synology.me, можно и просто внешний ip.

Ссылка на сообщение
Поделиться на другие сайты
В NAS меняете порт 5000 на любой другой. В модеме открываете порт 5000.

Только что на своём NAS проверил. Работает.

Вебморда не доступна, а DS cam работает.

В DS cam ввёл имя.synology.me, можно и просто внешний ip.

Чудеса!

У меня не работало.

Буду пробовать на других NASах.

 

Но вообще, мне непонятно как оно может работать...

Когда вы меняете порт 5000 на какой-то другой, пятитысячный по идее должен автоматически отключатся.

Ссылка на сообщение
Поделиться на другие сайты

Неа, не работает.

Ни по http ни по https

А что у вас на маршрутизаторе проброшено?

 

ЗЫ

Надо пройтись nmap-ом по портам NAS-а. Интересно он оставляет открытым порт 5000 если в настройках поменять порт на более другой?

Ссылка на сообщение
Поделиться на другие сайты
ЗЫ

Надо пройтись nmap-ом по портам NAS-а. Интересно он оставляет открытым порт 5000 если в настройках поменять порт на более другой?

Нет. Не оставляет. На что поменяли, то и светится...

Ссылка на сообщение
Поделиться на другие сайты
Нет. Не оставляет. На что поменяли, то и светится...

Значит и DSM будет светится на этом порту.

Ссылка на сообщение
Поделиться на другие сайты

Присоединяйтесь к обсуждению

Вы можете опубликовать сообщение сейчас, а зарегистрироваться позже. Если у вас есть аккаунт, войдите в него для написания от своего имени.

Гость
Ответить в этой теме...

×   Вставлено в виде отформатированного текста.   Вставить в виде обычного текста

  Разрешено не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отобразить как ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставить изображения напрямую. Загрузите или вставьте изображения по ссылке.

Загрузка...

×
×
  • Создать...