Перейти к содержанию
Форум русской поддержки продукции Synology

Web Station не работает


Рекомендованные сообщения

После включения Web Station не работает.

 

 

После включения Web Station:

На рабочем столе админки (DiskStation Manager) создается иконка Web Station, создается папка web.

При переходе по ссылкам на сайт перебрасывает на страницу входа в DiskStation Manager.

В папке web нет стандартных файлов index.html и index.php

 

В чем может быть проблема?

Ссылка на сообщение
Поделиться на другие сайты
В папке web нет стандартных файлов index.html и index.php

 

В чем может быть проблема?

Ну так создайте index.html или index.php.

Ссылка на сообщение
Поделиться на другие сайты
Служба Web Station включена. Теперь можно создать собственный веб-сайт на DiskStation. Выполните представленные ниже инструкции для создания и опубликования собственного веб-сайта в сети.

 

Войдите в веб-менеджер и перейдите на страницу "Права доступа > Папка общего доступа". Присвойте права пользователей для доступа к общей веб-папке.

(Создайте веб-страницы, и) Загрузите свои страницы в общую "веб" папку.

Убедитесь в том, что домашняя страница Вашего веб-сайта называется "index.php", "index.htm" или "index.html".

В адресной строке браузера введите http://servername/ чтобы просмотреть свой веб-сайт.

Ссылка на сообщение
Поделиться на другие сайты
  • 2 года спустя...

Подниму тему :-) Веб-сервер включен, файл index.html создан, всё работало - и извне, и внутри домашней сети. Вдруг как отрезало - редирект на 5000 и всё. Веб-сервер отключал/включал, папку /web вручную прибивал, не хочет работать - и всё тут. Где порыться, мож кто намекнет?

Ссылка на сообщение
Поделиться на другие сайты
А в роутер не заглядывал? Может проброс 80 порта слетел.

 

Нет, роутер непричем. Изнутри тоже не работало. Разобрался сам. Оказывается была опечатка в файле .htaccess. Убрал опечатку - все заработало вновь. 212j, DSM 4.0-2219. Поскольку подобный симптом на форуме не описан - предлагаю куда-нить в FAQ его: В случае неверных инструкций в файле .htaccess, несмотря на запущенную службу веб-сервера, обращение к аппарату по http вызовет безусловный редирект на порт админки. Причем как изнутри, так и снаружи.

Ссылка на сообщение
Поделиться на другие сайты
  • 2 месяца спустя...

А поподробнее можно.

У меня подобная ситуация.

Папка WEB есть.

файл index.html в ней есть. (локально на компе открывается корректно)

но все равно идет редирект на 5000 или 5001 порт.

файла .htaccess нет вообще.

 

Web Station выключал включал, не влияет вообще ни на что.

DS перегружал.

стабильно не работает.

 

про маршрутизатор и 80 порт не канает, не работает даже в локалке.

 

DS - DS411+II

Ссылка на сообщение
Поделиться на другие сайты
А поподробнее можно.

У меня подобная ситуация.

.........

напиши подробнее... как сеть построена, что именно требуется сделать (задача) ?

Ссылка на сообщение
Поделиться на другие сайты
напиши подробнее... как сеть построена, что именно требуется сделать (задача) ?

 

 

задача: поднять простенький сайт.

написан просто на http, без изысков (можно сказать просто пара страниц)

 

сеть тоже самая простая одноранговая с выходом в интернет.

в интернет пользователи ходят под одним адресом.

для DS используется другой адрес.

записанный в DNS за зарегистрированным доменом компании.

 

и кстати

редирект на DSM происходит даже при выключенном HTTPS и отключенном автоматическом перенаправлении.

 

Ссылка на сообщение
Поделиться на другие сайты

Присоединяйтесь к обсуждению

Вы можете опубликовать сообщение сейчас, а зарегистрироваться позже. Если у вас есть аккаунт, войдите в него для написания от своего имени.

Гость
Ответить в этой теме...

×   Вставлено в виде отформатированного текста.   Вставить в виде обычного текста

  Разрешено не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отобразить как ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставить изображения напрямую. Загрузите или вставьте изображения по ссылке.

Загрузка...
×
×
  • Создать...