Перейти к содержанию
Форум русской поддержки продукции Synology

Зависает (отваливается) Syno 213j


Рекомендованные сообщения

Имеем хранилище 213j (прошивка 5.1-5055) со статическим IP, который дает роутер ASUS RT-65N. На хранилище запущено dlna, transmission, cloud station. И периодически зависает хранилище (примерно 30-45 дней). Но в последнюю неделю приходиться перезагружать его каждый день. Симптомы такие:

я замечаю проседание скорости на transmission где-то до 1МБ/с или меньше (скорость канала 5 МБ/с);

пытаюсь с компа зайти в папку в сети, в которую заходит очень долго;

начинает тормозить по dlna фильм, который пять минут показывал без тормозов.

Понятно что симптомы все начинают происходит одновременно, просто какое я раньше замечу и как следствие: хранилище через какое-то время перестает вообще быть доступным из сети, не могу через веб зайти, а так же его не видит assisstent. Все лампочки не мигают и горят зеленым, мигает только lan.

Я заходил в веб-итерфейс, когда хранилище еще не совсем зависло, а еще более-менее крутится. Пытался отключать пакеты приложения, смотреть логи и т.д., через какое-то время виснет намертво. Загрузка процессора в норме, оперативка тоже, температура тоже. Зависания происходили и на предыдущих прошивках, с другими запущенными приложениями (Download Station, Сервер мультимедия и т.д.). После перезагрузки из веба или с кнопки (если не успею) начинает работать в штатном режиме. Вообщем помогите советом! А то я уже думаю попробовать роутер поменять для чистоты эксперимента...

Ссылка на сообщение
Поделиться на другие сайты

Попробуйте для начала переустановить систему через 2-й RESET -> 3. Сброс для переустановки операционной системы

Ссылка на сообщение
Поделиться на другие сайты
  • 1 месяц спустя...
Попробуйте для начала переустановить систему через 2-й RESET -> 3. Сброс для переустановки операционной системы

переустановил систему через 2 reset на версию 5.1-5055 и спустя месяц ситуация повторилась с теми же симптомами... Что еще посоветуете?

Ссылка на сообщение
Поделиться на другие сайты
переустановил систему через 2 reset на версию 5.1-5055 и спустя месяц ситуация повторилась с теми же симптомами... Что еще посоветуете?

Даже сложно что-то ещё посоветовать ибо DSM 5.1-5055 из последних пока считается самой стабильной. Ну разве что загрубить параметры трансмишена в плане скорости, выключить DHT и тп ...

 

PS Всё таки модели J-класса комплектуются более слабым типом процессора.

Ссылка на сообщение
Поделиться на другие сайты

Мыслю, в одной теме удобнее обсуждать.

Аналогичная история случилась с DS415+ под DSM 5.2-5592 Update 3. Внешне - ни с чего. Фильм по сети /samba/ смотрели, десяток раздач transmission + пару DS, по веб я с OpenVPN ковырялся. И вдруг NAS повис. Все индикаторы горят зеленым/синим, а доступа по сети нет /пробовал веб, SSH, DS find/. Ситуация возникла неожиданно, не был готов. Пробежался быстро по форуму, нашел вот эту тему, попробовал RESET - DS никак не отреагировал на 4+ нажатие RESET. Тогда я просто отключил питание. Через некоторое время включил - DS завелся, но почти сразу сам выключился. Я его опять включил - завелся и до сих пор работает, как-будто ничего и не было. В /var/log/synolog/synosys.log только вот это /с учетом времени падения/:

info 2015/08/31 21:35:19 user: System successfully enabled DDNS update.

info 2015/08/31 21:35:23 SYSTEM: System successfully registered [xxx.xxx.xxx.xxx] to [xxx.synology.me] in

warning 2015/08/31 22:55:43 SYSTEM: Local UPS was plugged in.

info 2015/08/31 22:55:56 SYSTEM: System started to boot up.

warning 2015/08/31 22:56:01 SYSTEM: System booted up from an improper shutdown.

err 2015/08/31 22:56:02 SYSTEM: Failed to send email. (Failed to resolve host address.).

info 2015/08/31 22:56:25 SYSTEM: IP address [169.254.114.78] and subnet mask [255.255.0.0] were assigned to the DHCP client on [LAN 1].

info 2015/08/31 22:56:26 SYSTEM: IP address [169.254.156.27] and subnet mask [255.255.0.0] were assigned to the DHCP client on [LAN 2].

info 2015/08/31 22:56:32 SYSTEM: [Cloud Sync] service was started.

err 2015/08/31 22:59:35 SYSTEM: System failed to get External IP.

info 2015/08/31 23:05:37 SYSTEM: System successfully registered [xxx.xxx.xxx.xxx] to [xxx.synology.me] in DDNS server [synology].

info 2015/08/31 23:13:03 SYSTEM: Server started counting down to shutdown.

warning 2015/08/31 23:15:07 SYSTEM: Local UPS was plugged in.

info 2015/08/31 23:15:21 SYSTEM: System started to boot up.

info 2015/08/31 23:15:24 SYSTEM: System successfully registered [xxx.xxx.xxx.xxx] to [xxx.synology.me] in DDNS server [synology].

info 2015/08/31 23:15:33 SYSTEM: [Cloud Sync] service was started.

info 2015/08/31 23:15:50 SYSTEM: IP address [169.254.156.27] and subnet mask [255.255.0.0] were assigned to the DHCP client on [LAN 2].

Есть какие-то версии?

Ссылка на сообщение
Поделиться на другие сайты
"Какие надо" "лежат" в папке /var/log ...

ОК. Судя по всему, падение системы имело место в 22:25 Запуск в 22:55

/var/log/kern.log - все чисто.

/var/log/scemd.log - все чисто, часа 3 перед падением каждые 20 минут напоминает о внешнем диске:

Aug 31 22:23:06 user scemd: polling_usb_hibernation.c:265 The USB disk 1 wake up from hibernation.

/var/log/syslog.log - все чисто.

/var/log/synoservice.log - все чисто.

/var/log/synopkg.log - были запущены DownloadStation, CloudSync, transmission и mc, а незадолго до падения - VPNCenter:

2015/08/31 21:38:05 start VPNCenter: begin to start version 1.2-2438

2015/08/31 21:38:36 start VPNCenter: start version 1.2-2438 successfully, result 0

/var/log/messages - прямо перед падением была фатальная ошибка демона L2TP:

Aug 31 22:01:12 user xl2tpd[7456]: IPsec SAref does not work with L2TP kernel mode yet, enabling force userspace=yes

Aug 31 22:01:12 user xl2tpd[7456]: setsockopt recvref[30]: Protocol not available

Aug 31 22:01:12 user ipsec_setup: Starting Openswan IPsec U2.6.42-31-g989bea2/K3.10.35...

Aug 31 22:01:13 user ipsec_setup: Using NETKEY(XFRM) stack

Aug 31 22:01:13 user ipsec_setup: ...Openswan IPsec started

Aug 31 22:01:13 user pluto: adjusting ipsec.d to /etc/ipsec.d

Aug 31 22:01:13 user pluto: bind() will be filtered for 192.168.1.100

Aug 31 22:01:13 user ipsec__plutorun: adjusting ipsec.d to /etc/ipsec.d

Aug 31 22:01:13 user ipsec__plutorun: bind() will be filtered for 192.168.1.100

Aug 31 22:01:13 user ipsec__plutorun: 002 added connection description "L2TP-PSK-NAT"

Aug 31 22:01:13 user ipsec__plutorun: 002 added connection description "L2TP-PSK-noNAT"

Aug 31 22:25:34 user xl2tpd[7457]: death_handler: Fatal signal 15 received

Aug 31 22:25:34 user ipsec_setup: Stopping Openswan IPsec...

Aug 31 22:25:36 user ipsec_setup: ...Openswan IPsec stopped

................................................................................

................................................................................

Aug 31 22:55:39 user kernel: [ 0.000000] ACPI: RSDP 000000007f7fe014 00024 (v02 INSYDE)

Какие еще логи важны?

Ссылка на сообщение
Поделиться на другие сайты
Обычно достаточно /var/log/messages (если разборки с питанием + /var/log/scemd.log)

/var/log/scemd.log чистый. Там просто удачно получилось, NAS по расписанию отключился и стартовал в 9 утра, то есть все хорошо видно и понятно.

Получается, судя по /var/log/messages, дело в работе приложения VPN server, так?

Ссылка на сообщение
Поделиться на другие сайты
Получается, судя по /var/log/messages, дело в работе приложения VPN server, так?

Не исключено. По DSM 5.2-5592 были жалобы на некорректную работу пакета VPN Server - детали точно не помню ...

Ссылка на сообщение
Поделиться на другие сайты

В тему. Такая же проблема с зависанием ds415play. Приобрел примерно месяц назад. Через недели две ни с того ни с сего обнаружил, что НАС не доступен. Лампочки горят. Перезапустить удалось путем перевыдергивания шнура питания. После перезагрузки все ок.

Через несколько дней ситуация повторяется. Все лампочки горят првильным цветом, а доступа к насу нет. При чем ххд индикаторы не мигают, хотя должны изза торрентов. Жму кнопку питания - Нас пискнул и выключился: статус горит зеленым, ххд потухли, кнопка питания мигает синим. Из этого состояния привести Нас в чувства штатными методами (нажатием, удержанием кнопки питания, ожиданием чуда) не удалось. После перевытыка кабеля питания Нас загрузился и заработал как ни в чем ни бывало.

 

Параметры:

DS415PLAY ось актуальная 5.2 upd3

3x Hgst nas 3Tb

Роутер zyxel keenetic

Ибп нет пока

Температура и режим в норме

Включены стандартные протоколы, кроме ftp

Приложения стандартные официальные: file, photo, audio, video, mmedia, download, cloud (включен но пока не использую),

Антивирь ессентиал (стандартный). Без плановой проверки

VPN не установлен!!

Интернет 100/100, нареканий нет

Торренты 24/7 активны, поэтому в теории уснуть Нас и диски не должны

IP внешний с момента установки не менялся ) В локалке для Наса внутренний айпи закрепил

 

Если у кого есть подобная проблема или решение, поделитесь пожалуйста. Я абсолютный нуб в этих делах. :)

Субъективно могу предположить два потенциальные причины:

1. Что-то с эл-вом. Надо ИБП.

2. Что-то с торрентами в увязке с безопасностью. Быть может сам Нас что-то автоматом блокирует, воспринимая за "нападения". Хз

 

Зы. Даже думать не хочу, что Нас бракованный. Ведь не докажешь! Закономерностей в зависании пока не просматривается, статистики нет.

Ссылка на сообщение
Поделиться на другие сайты

Для начала повыключайте все галки на предмет "спящего режима". Может НАС не может корректно проснуться ;)

 

PS Включенная торрентокачалка - это ещё не 100%-я гарантия что спать не будет (всё что надо скачали а пиров на ваши раздачи и нет ;) )

 

PS И озвучьте версию DSM плз ..

Ссылка на сообщение
Поделиться на другие сайты

Благодарю за быстрый ответ!

 

DSM 5.2-5592 update 3.

 

Торренты все скачены, только на раздачу работают. Но всегда есть активные. Тут уверен. Проверяю регулярно ;)

 

Настройки усыпления и выхода не менял. Все дефолтное.

 

 

Ссылка на сообщение
Поделиться на другие сайты
Торренты все скачены, только на раздачу работают. Но всегда есть активные. Тут уверен. Проверяю регулярно ;)

Не факт. Когда зависает - уже не проверишь ;)

 

Настройки усыпления и выхода не менял. Все дефолтное.

"Не менял" - не значит проверил ;) Проверьте ещё раз.

 

DSM 5.2-5592 update 3.

у кого-то уже было похожее на 5.2-5592 (sobol) - "вылечилось" даунгрейдом на 5.1-5055

 

 

Ссылка на сообщение
Поделиться на другие сайты
у кого-то уже было похожее на 5.2-5592 (sobol) - "вылечилось" даунгрейдом на 5.1-5055

 

 

Благодарю. Где-то читал, что даунгрейд на синолоджи нельзя. Раз пишите тут значит можно)

В любом случае даунгрейд это временная полумера без гарантии решения проблемы. Хочется надеятся, будет следующий апдейт с устраненипм проблемы.

 

В любом случае премного благодарен за оперативные ответы и пищу для размышления;)

Продолжу танцы с бубеном)

Ссылка на сообщение
Поделиться на другие сайты
у кого-то уже было похожее на 5.2-5592 (sobol) - "вылечилось" даунгрейдом на 5.1-5055

Не факт, что у меня было то же самое - мои симптомы были "НАС недоступен после включения по расписанию". Судя по тому, что индикаторы работали штатно, но он не был доступен из сети - причин море. Но подобное поведение я на своём DS212j наблюдал только на одной из версий ветки 4 и вот на 5.2 несколько раз. Так как проблема всплывала только тогда, когда я уходил на работу то по горячим следам её диагностировать не получалось, а после перезагрузки следов каких либо сбоев в логах не находилось. Сейчас, когда из-за кривой поддержки моего UPS да и вообще изначальной кривизны порддержки UPS на 5.2 я откатился на 5.1 более месяца назад на 5.1.5055 мой НАС ни разу не глючил после старта по расписанию.

ИМХО версия 5.1.5055 одна из самых стабильнейших. Это несмотря на постоянные фиксы дыр в безопасности и фиксы фиксов криворуких синопроггеров, которые в последнее время что то часто грохают куски рабочего и добавляют куски кривого кода.

Ссылка на сообщение
Поделиться на другие сайты
  • 7 месяцев спустя...

В общем тоже, что и у остальных в этой ветке: 213j, 5.2-5644 Update 3, статический IP, корректно определяемый ИБП, роутер ZyXEL Ultra II. Проблема началась, когда не было ИБП и был другой роутер. На DSM пакеты Cloud Sync, VPN Server, Surveillance Station, Photo Station.

 

Где-то примерно раз в месяц без видимых причин NAS становится недоступен: в ЛВС по IP в браузере не зайти, через мобильные приложения (DS Cam, DS File) не достучаться, камеры его не видят, общие папки на ПК недоступны. Диоды на 213j моргают как обычно, NAS перезагружаю кнопкой питания (на нее реагирует прекрасно), после перезагрузки никаких следов проблем.

 

С какого-то момента VPN стал недоступен извне. Попробую удалить VPN Server и Photo Station (не пользуюсь почти). Посмотрю поможет или нет.

Ссылка на сообщение
Поделиться на другие сайты
  • 2 недели спустя...
В общем тоже, что и у остальных в этой ветке: 213j, 5.2-5644 Update 3, статический IP, корректно определяемый ИБП, роутер ZyXEL Ultra II. Проблема началась, когда не было ИБП и был другой роутер. На DSM пакеты Cloud Sync, VPN Server, Surveillance Station, Photo Station.

 

Где-то примерно раз в месяц без видимых причин NAS становится недоступен: в ЛВС по IP в браузере не зайти, через мобильные приложения (DS Cam, DS File) не достучаться, камеры его не видят, общие папки на ПК недоступны. Диоды на 213j моргают как обычно, NAS перезагружаю кнопкой питания (на нее реагирует прекрасно), после перезагрузки никаких следов проблем.

 

С какого-то момента VPN стал недоступен извне. Попробую удалить VPN Server и Photo Station (не пользуюсь почти). Посмотрю поможет или нет.

 

Удаление пакетов VPN Server и Photo Station не помогло, сегодня Synology снова завис. С момента последнего зависания прошло около 2-х недель. Решился-таки обновится на DSM 6, может поможет.

Ссылка на сообщение
Поделиться на другие сайты
сегодня Synology снова завис. С момента последнего зависания прошло около 2-х недель. Решился-таки обновится на DSM 6, может поможет.

Ждём апдейт от sobol про его сино-нирвану ... ;)

Ссылка на сообщение
Поделиться на другие сайты
Ждём апдейт от sobol про его сино-нирвану ... ;)

Всем доброго времени суток и с майскими праздниками!

В моём случае я не наблюдал нирвану довольно давно, но!

1. У меня на NAS стоит получение адреса по DHCP. Для меня - достаточно, потому что роутер не поддерживает настройку по UPNP (а другие приблуды вроде не требовательны к типу адреса статика\динамика).

2. На роутере настроена постоянная аренда адреса для MAC адреса NAS.

3. Проброс портов и прочего сделан средствами файрвола на роутере на нужный мне список портов (приложений).

4. Брандмауэр NAS вручную настроен на полный доступ из локальной сети и фильтрацию остальных подключений.

4. Дома у меня подключение по FTTB и стоит старенький TP-Link 1043ND с OpenWRT.

 

P.S. Подобное поведение было и на версии 5.1 и на текущей 6.0, 5.2 я не ставил из-за кривой подержки UPS.

Ссылка на сообщение
Поделиться на другие сайты
Удаление пакетов VPN Server и Photo Station не помогло, сегодня Synology снова завис. С момента последнего зависания прошло около 2-х недель. Решился-таки обновится на DSM 6, может поможет.

 

Обновился до последней версии DSM 6, обновил пакеты, полет нормальный :-) Видеонаблюдение, синхронизация в облако, доступ со смартфона, взаимодействие с ИБП (переход в безопасный режим и обратно), ... все работает как и прежде, использование CPU и RAM в норме. Отпишусь как зависнет :-)

Ссылка на сообщение
Поделиться на другие сайты

Присоединяйтесь к обсуждению

Вы можете опубликовать сообщение сейчас, а зарегистрироваться позже. Если у вас есть аккаунт, войдите в него для написания от своего имени.

Гость
Ответить в этой теме...

×   Вставлено в виде отформатированного текста.   Вставить в виде обычного текста

  Разрешено не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отобразить как ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставить изображения напрямую. Загрузите или вставьте изображения по ссылке.

Загрузка...
×
×
  • Создать...