IPB

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> Asterisk+Huawei E1150, Как собрать
interminable
сообщение 22.4.2015, 12:40
Сообщение #1


Участник
**

Группа: Пользователи
Сообщений: 15
Регистрация: 22.4.2015
Пользователь №: 9239



Товарищи, я немного далек от линукса, можете обьяснить "на пальцах" как приручить asterisk к модему Huawei E1150.
Подробная инструкция будет самое то.
Спасибо.
Перейти в начало страницы
 
+Цитировать сообщение
sidor_ii
сообщение 22.4.2015, 22:34
Сообщение #2


Активный участник
***

Группа: Пользователи
Сообщений: 941
Регистрация: 10.9.2009
Пользователь №: 205



Цитата(interminable @ 22.4.2015, 12:40) *
Товарищи, я немного далек от линукса, можете обьяснить "на пальцах" как приручить asterisk к модему Huawei E1150.
Подробная инструкция будет самое то.
Спасибо.

Подробнее не бывает:
http://wiki.e1550.mobi/doku.php?id=Main%20page


--------------------
DS1512+ - DSM6.хх
Microserver Gen8
Mikrotik RB 1100AHx2
Перейти в начало страницы
 
+Цитировать сообщение
interminable
сообщение 23.4.2015, 9:10
Сообщение #3


Участник
**

Группа: Пользователи
Сообщений: 15
Регистрация: 22.4.2015
Пользователь №: 9239



Chan_dongle runs only in asterisk 1.6.2 and asterisk 1.8. Asterisk 1.4 is not supported.

прямо там и написано, а актуальная версия астериска 1.8 на синолоджи.
Перейти в начало страницы
 
+Цитировать сообщение
sidor_ii
сообщение 23.4.2015, 9:20
Сообщение #4


Активный участник
***

Группа: Пользователи
Сообщений: 941
Регистрация: 10.9.2009
Пользователь №: 205



Цитата(interminable @ 23.4.2015, 9:10) *
Chan_dongle runs only in asterisk 1.6.2 and asterisk 1.8. Asterisk 1.4 is not supported.

прямо там и написано, а актуальная версия астериска 1.8 на синолоджи.

Ну на самом деле Chan_dongle работает на любом Астериске вплоть до 13.
В интернете можно найти патченные исходники.
p.s. Да и мануалов по компиляции и настройке Chan_dongle Яндекс находит туеву хучу.
Нет смысла переписывать их сюда.
p.s.s.
Просто поставив "галочку" в web gui подключить сhan_dongle не получится.
Без работы в командной строке делать нечего.


--------------------
DS1512+ - DSM6.хх
Microserver Gen8
Mikrotik RB 1100AHx2
Перейти в начало страницы
 
+Цитировать сообщение
interminable
сообщение 23.4.2015, 9:46
Сообщение #5


Участник
**

Группа: Пользователи
Сообщений: 15
Регистрация: 22.4.2015
Пользователь №: 9239



Ну дык я и прошу показать как в эту строку попасть и че в ней писать...
Перейти в начало страницы
 
+Цитировать сообщение
alexejnic
сообщение 23.4.2015, 14:26
Сообщение #6


Активный участник
***

Группа: Пользователи
Сообщений: 719
Регистрация: 1.10.2010
Пользователь №: 1298



Здесь читай для старых версий Астериск ну а тута для новых.
Но если не знаешь как в командную строку попасть, лучше даже и не пытайся.
Перейти в начало страницы
 
+Цитировать сообщение
interminable
сообщение 15.6.2015, 16:58
Сообщение #7


Участник
**

Группа: Пользователи
Сообщений: 15
Регистрация: 22.4.2015
Пользователь №: 9239



У меня затык на:
./configure --with-asterisk=/opt/include
make
cp chan_dongle.so /opt/lib/asterisk/modules/
cp etc/dongle.conf /opt/etc/asterisk/

мало того, что таких путей тупо нет, так еще и ошибку бьет:
-ash: ./configure: not found
DiskStation> cd /volume1/tmp/dongle/
DiskStation> cd chan_dongle-1.1.r14
DiskStation> ./configure --with-asterisk=/opt/include
checking build system type... armv5tel-unknown-linux-gnueabi
checking host system type... armv5tel-unknown-linux-gnueabi
checking target system type... armv5tel-unknown-linux-gnueabi
checking for a BSD-compatible install... ./install-sh -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... no
checking for gcc... no
checking for cl... no
checking for cc... no
configure: error: in `/volume1/tmp/dongle/chan_dongle-1.1.r14':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
Перейти в начало страницы
 
+Цитировать сообщение
sidor_ii
сообщение 15.6.2015, 21:02
Сообщение #8


Активный участник
***

Группа: Пользователи
Сообщений: 941
Регистрация: 10.9.2009
Пользователь №: 205



Цитата(interminable @ 15.6.2015, 16:58) *
configure: error: in `/volume1/tmp/dongle/chan_dongle-1.1.r14':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

Вам для сборки chan_dongle не хватает предустановленных пакетов.
Первый на который ругается это " C compiler "
Поищите в яндексе на тему: "chan_dongle из исходников"
Поймете какие пакеты надо поставить.
p.s.
тут http://www.synology-forum.ru/index.php?sho...=1654&st=40
alexejnic достаточно все подробно расписал.
Может поможет.


--------------------
DS1512+ - DSM6.хх
Microserver Gen8
Mikrotik RB 1100AHx2
Перейти в начало страницы
 
+Цитировать сообщение
alexejnic
сообщение 16.6.2015, 11:25
Сообщение #9


Активный участник
***

Группа: Пользователи
Сообщений: 719
Регистрация: 1.10.2010
Пользователь №: 1298



Сразу видно нет пакета make, нет пакета gcc ну и т.д.
Второе ./configure --with-asterisk=/opt/include относится только к Asterisk поставленному из ipkg. Версия из центра пакетов не канает, в ней нет инклюдов.
Поэтому любители обновляться чтобы всё иметь из коробки курите в сторонке. Из коробки все иметь вы никогда не будете.
А так в opkg уже есть chan_dongle но для лучшей совместимости я считаю лучше удалить Астериск из центра пакетов и поставить из opkg.
Чтобы кусками не ставить можно сделать так.
Код
opkg list | grep asterisk18- | sed 's/ - .*//' | xargs opkg install

и всё что нужно само прилетит в том числе и chan_dongle
Перейти в начало страницы
 
+Цитировать сообщение
interminable
сообщение 21.7.2015, 20:28
Сообщение #10


Участник
**

Группа: Пользователи
Сообщений: 15
Регистрация: 22.4.2015
Пользователь №: 9239



Цитата(alexejnic @ 16.6.2015, 11:25) *
Сразу видно нет пакета make, нет пакета gcc ну и т.д.
Второе ./configure --with-asterisk=/opt/include относится только к Asterisk поставленному из ipkg. Версия из центра пакетов не канает, в ней нет инклюдов.
Поэтому любители обновляться чтобы всё иметь из коробки курите в сторонке. Из коробки все иметь вы никогда не будете.
А так в opkg уже есть chan_dongle но для лучшей совместимости я считаю лучше удалить Астериск из центра пакетов и поставить из opkg.
Чтобы кусками не ставить можно сделать так.
Код
opkg list | grep asterisk18- | sed 's/ - .*//' | xargs opkg install

и всё что нужно само прилетит в том числе и chan_dongle

Вот спасибо добрый человек!

Collected errors:
* check_data_file_clashes: Package asterisk18-cdr wants to install file /Apps/opt/etc/asterisk/cdr_manager.conf
But that file is already provided by package * asterisk18
* opkg_install_cmd: Cannot install package asterisk18-cdr.
* check_data_file_clashes: Package asterisk18-voicemail wants to install file /Apps/opt/lib/asterisk/modules/res_smdi.so
But that file is already provided by package * asterisk18-res-smdi
* opkg_install_cmd: Cannot install package asterisk18-voicemail.
xargs: opkg: exited with status 255; aborting
Перейти в начало страницы
 
+Цитировать сообщение

Ответить в данную темуНачать новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



Текстовая версия Сейчас: 24.9.2020, 6:20
Bridged By IpbWiki: Integration Of Invision Power Board and MediaWiki © GlobalSoft